Welcome, Guest. Please login or register.
October 20, 2018, 08:17:22 PM
Home Help Search Calendar Login Register
News: Please note: Anyone posting ads not relating to FBI or FBI games or posting other unsolicited spam will be removed from this forum, will have all their posts removed, and will be banned from rejoining.

*** DO NOT POST SPAM!!! ***

Want to become a member???

Due to the huge amount of spam, registration is now completely manual. To become a member of the board, send an email to:

craig@october.com.au

Please be sure to include some info about the games you play so we know you're serious and not a spammer!! :-) Also choose a username (maybe one of your player names?).
We'll reply with your login details.

+  Flying Buffalo Forums
|-+  General Discussions
| |-+  News and Events
| | |-+  Updates
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: Updates  (Read 792 times)
Craig Delahoy
Administrator
Full Member
*****
Offline Offline

Posts: 92



View Profile WWW
« on: April 02, 2017, 02:17:29 PM »

Hi all.

Today I decided I should upgrade the forum software. Big mistake! Seems SMF's wonderful auto-upgrade options are pretty much ALL prone to bugs of one sort or another.

Fortunately, I'd made a backup of the entire forum database beforehand, so I was eventually able to restore everything. If you've lost any info, I apologise.

Craig
Logged
Craig Delahoy
Administrator
Full Member
*****
Offline Offline

Posts: 92



View Profile WWW
« Reply #1 on: April 03, 2017, 06:02:47 PM »

Even after restoring everything, I've still seen an important file change (when it shouldn't) and causing an error. This is annoying.
Logged
Craig Delahoy
Administrator
Full Member
*****
Offline Offline

Posts: 92



View Profile WWW
« Reply #2 on: April 07, 2017, 11:07:01 AM »

Seems to be happening at least daily. Always the same file (even if I rename it), and always the same line. Please bear with me as I attempt to workaround this painful issue.
Logged
Craig Delahoy
Administrator
Full Member
*****
Offline Offline

Posts: 92



View Profile WWW
« Reply #3 on: January 30, 2018, 05:28:53 PM »

Hi all. The forums are back online. I've also tried to upgrade from the very old version of SMF that it was using. The upgrade wasn't totally successful and I only managed to move from 1.0.8 to 1.0.16. The latest stable version is actually 2.0.14, but I can't get past the one installed without error. Please let me know if you find any issues ...
Logged
Craig Delahoy
Administrator
Full Member
*****
Offline Offline

Posts: 92



View Profile WWW
« Reply #4 on: September 24, 2018, 10:01:37 PM »

Hi again. Seems the upgrade demons came to bite me on the bum over the weekend.

If you've followed any of my update earlier update posts - and there's no reason you should have; you have a life - you'd be aware that upgrading this forum software is no mean feat. So I have been leaving it at a very old version for a long time, only because later version updates were giving me no end of errors. Now, things like updates to SQL and PHP, even the old version was failing. :-(

Time to bite te bullet.

This afternoon I spent untold hours updating the forum software from v1.0.16 (written in Feb 2009!!) all the way up to v 1.1.21 (dated April 2015!!)  Yay!

My apologies for all the downtime this required. Hopefully, this is now running a stable, modern version of the software, and no one has lost any data.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!